Help-通过docker-compose安装, 运行容器时的错误

安装报错 · lyons · 于 9个月前 发布 · 1468 次阅读

在github上也提问了: https://github.com/fecshop/yii2_fecshop_docker/issues/4

你好! 我的环境是在vbox下运行centos7, 在vbox中设置共享文件夹存放yii2_fecshop_docker项目并挂载到centos7的/media/sf_yii2_fecshop_docker-master路径下, docker版本为17.12.0-ce, compose版本为1.19. 按照教程执行到sudo docker-compose exec mysql bash 时出现如下错误: Error response from daemon: Container ce724caeac461d0fc8dab9abde680602d5f31b21584eb00b73a9bac9a19e8cf8 is restarting, wait until the container is running

sudo docker-compose ps 信息如下

Name Command State Ports
sfyii2fecshopdockermaster180304_mongodb_1 docker-entrypoint.sh mongod Restarting
sfyii2fecshopdockermaster180304_mysql_1 docker-entrypoint.sh mysqld Restarting
sfyii2fecshopdockermaster180304_php_1 docker-php-entrypoint php-fpm Up 9000/tcp
sfyii2fecshopdockermaster180304_redis_1 docker-entrypoint.sh bash ... Restarting
sfyii2fecshopdockermaster180304_web_1 nginx -g daemon off; Up 0.0.0.0:80->80/tcp
sfyii2fecshopdockermaster180304_xunsearch_1 sh bin/xs-docker.sh Up 8383/tcp, 8384/tcp

sudo docker-compose logs 信息如下

Attaching to sfyii2fecshopdockermaster180304_web_1, sfyii2fecshopdockermaster180304_php_1, sfyii2fecshopdockermaster180304_mysql_1, sfyii2fecshopdockermaster180304_redis_1, sfyii2fecshopdockermaster180304_mongodb_1, sfyii2fecshopdockermaster180304_xunsearch_1
php_1 | [05-Mar-2018 02:45:25] NOTICE: fpm is running, pid 1
php_1 | [05-Mar-2018 02:45:25] NOTICE: ready to handle connections
mysql_1 |
mysql_1 | ERROR: mysqld failed while attempting to check config
mysql_1 | command was: "mysqld --verbose --help"
mysql_1 |
mysql_1 | mysqld: Can't read dir of '/etc/mysql/conf.d/' (Errcode: 13 - Permission denied)
mysql_1 | mysqld: [ERROR] Fatal error in defaults handling. Program aborted!
mysql_1 |
mysql_1 | ERROR: mysqld failed while attempting to check config
mysql_1 | command was: "mysqld --verbose --help"
mysql_1 |
mysql_1 | mysqld: Can't read dir of '/etc/mysql/conf.d/' (Errcode: 13 - Permission denied)
mysql_1 | mysqld: [ERROR] Fatal error in defaults handling. Program aborted!
mysql_1 |
mysql_1 | ERROR: mysqld failed while attempting to check config
mysql_1 | command was: "mysqld --verbose --help"
mysql_1 |
mysql_1 | mysqld: Can't read dir of '/etc/mysql/conf.d/' (Errcode: 13 - Permission denied)
mysql_1 | mysqld: [ERROR] Fatal error in defaults handling. Program aborted!
mysql_1 |
mysql_1 | ERROR: mysqld failed while attempting to check config
mysql_1 | command was: "mysqld --verbose --help"
mysql_1 |
mysql_1 | mysqld: Can't read dir of '/etc/mysql/conf.d/' (Errcode: 13 - Permission denied)
mysql_1 | mysqld: [ERROR] Fatal error in defaults handling. Program aborted!
mysql_1 |
mysql_1 | ERROR: mysqld failed while attempting to check config
mysql_1 | command was: "mysqld --verbose --help"
mysql_1 |
mysql_1 | mysqld: Can't read dir of '/etc/mysql/conf.d/' (Errcode: 13 - Permission denied)
mysql_1 | mysqld: [ERROR] Fatal error in defaults handling. Program aborted!
mysql_1 |
mysql_1 | ERROR: mysqld failed while attempting to check config
mysql_1 | command was: "mysqld --verbose --help"
mysql_1 |
mysql_1 | mysqld: Can't read dir of '/etc/mysql/conf.d/' (Errcode: 13 - Permission denied)
mysql_1 | mysqld: [ERROR] Fatal error in defaults handling. Program aborted!
mysql_1 |
mysql_1 | ERROR: mysqld failed while attempting to check config
mysql_1 | command was: "mysqld --verbose --help"
mysql_1 |
mysql_1 | mysqld: Can't read dir of '/etc/mysql/conf.d/' (Errcode: 13 - Permission denied)
mysql_1 | mysqld: [ERROR] Fatal error in defaults handling. Program aborted!
mysql_1 |
mysql_1 | ERROR: mysqld failed while attempting to check config
mysql_1 | command was: "mysqld --verbose --help"
mysql_1 |
mysql_1 | mysqld: Can't read dir of '/etc/mysql/conf.d/' (Errcode: 13 - Permission denied)
mysql_1 | mysqld: [ERROR] Fatal error in defaults handling. Program aborted!
mysql_1 |
mysql_1 | ERROR: mysqld failed while attempting to check config
mysql_1 | command was: "mysqld --verbose --help"
mysql_1 |
mysql_1 | mysqld: Can't read dir of '/etc/mysql/conf.d/' (Errcode: 13 - Permission denied)
mysql_1 | mysqld: [ERROR] Fatal error in defaults handling. Program aborted!
redis_1 | 1:C 05 Mar 02:45:23.029 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
redis_1 | 1:C 05 Mar 02:45:23.030 # Redis version=4.0.8, bits=64, commit=00000000, modified=0, pid=1, just started
redis_1 | 1:C 05 Mar 02:45:23.030 # Configuration loaded
redis_1 | 1:M 05 Mar 02:45:23.031 * Running mode=standalone, port=6379.
redis_1 | 1:M 05 Mar 02:45:23.031 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
redis_1 | 1:M 05 Mar 02:45:23.031 # Server initialized
redis_1 | 1:M 05 Mar 02:45:23.032 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
redis_1 | 1:M 05 Mar 02:45:23.032 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
redis_1 | 1:M 05 Mar 02:45:23.032 # Fatal error loading the DB: Permission denied. Exiting.
redis_1 | 1:C 05 Mar 02:45:25.005 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
redis_1 | 1:C 05 Mar 02:45:25.005 # Redis version=4.0.8, bits=64, commit=00000000, modified=0, pid=1, just started
redis_1 | 1:C 05 Mar 02:45:25.006 # Configuration loaded
redis_1 | 1:M 05 Mar 02:45:25.007 * Running mode=standalone, port=6379.
redis_1 | 1:M 05 Mar 02:45:25.007 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
redis_1 | 1:M 05 Mar 02:45:25.007 # Server initialized
redis_1 | 1:M 05 Mar 02:45:25.007 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
redis_1 | 1:M 05 Mar 02:45:25.007 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
redis_1 | 1:M 05 Mar 02:45:25.007 # Fatal error loading the DB: Permission denied. Exiting.
redis_1 | 1:C 05 Mar 02:45:26.593 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
redis_1 | 1:C 05 Mar 02:45:26.593 # Redis version=4.0.8, bits=64, commit=00000000, modified=0, pid=1, just started
redis_1 | 1:C 05 Mar 02:45:26.593 # Configuration loaded
redis_1 | 1:M 05 Mar 02:45:26.594 * Running mode=standalone, port=6379.
redis_1 | 1:M 05 Mar 02:45:26.594 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
redis_1 | 1:M 05 Mar 02:45:26.594 # Server initialized
redis_1 | 1:M 05 Mar 02:45:26.594 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
redis_1 | 1:M 05 Mar 02:45:26.594 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
redis_1 | 1:M 05 Mar 02:45:26.594 # Fatal error loading the DB: Permission denied. Exiting.
redis_1 | 1:C 05 Mar 02:45:27.454 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
redis_1 | 1:C 05 Mar 02:45:27.454 # Redis version=4.0.8, bits=64, commit=00000000, modified=0, pid=1, just started
redis_1 | 1:C 05 Mar 02:45:27.454 # Configuration loaded
redis_1 | 1:M 05 Mar 02:45:27.455 * Running mode=standalone, port=6379.
redis_1 | 1:M 05 Mar 02:45:27.455 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
redis_1 | 1:M 05 Mar 02:45:27.455 # Server initialized
redis_1 | 1:M 05 Mar 02:45:27.455 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
redis_1 | 1:M 05 Mar 02:45:27.455 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
redis_1 | 1:M 05 Mar 02:45:27.455 # Fatal error loading the DB: Permission denied. Exiting.
redis_1 | 1:C 05 Mar 02:45:28.736 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
redis_1 | 1:C 05 Mar 02:45:28.736 # Redis version=4.0.8, bits=64, commit=00000000, modified=0, pid=1, just started
redis_1 | 1:C 05 Mar 02:45:28.736 # Configuration loaded
redis_1 | 1:M 05 Mar 02:45:28.737 * Running mode=standalone, port=6379.
redis_1 | 1:M 05 Mar 02:45:28.737 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
redis_1 | 1:M 05 Mar 02:45:28.737 # Server initialized
redis_1 | 1:M 05 Mar 02:45:28.737 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
redis_1 | 1:M 05 Mar 02:45:28.737 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
redis_1 | 1:M 05 Mar 02:45:28.737 # Fatal error loading the DB: Permission denied. Exiting.
redis_1 | 1:C 05 Mar 02:45:30.649 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
redis_1 | 1:C 05 Mar 02:45:30.649 # Redis version=4.0.8, bits=64, commit=00000000, modified=0, pid=1, just started
redis_1 | 1:C 05 Mar 02:45:30.649 # Configuration loaded
redis_1 | 1:M 05 Mar 02:45:30.650 * Running mode=standalone, port=6379.
redis_1 | 1:M 05 Mar 02:45:30.650 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
redis_1 | 1:M 05 Mar 02:45:30.650 # Server initialized
redis_1 | 1:M 05 Mar 02:45:30.650 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
redis_1 | 1:M 05 Mar 02:45:30.650 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
redis_1 | 1:M 05 Mar 02:45:30.650 # Fatal error loading the DB: Permission denied. Exiting.
redis_1 | 1:C 05 Mar 02:45:34.148 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
redis_1 | 1:C 05 Mar 02:45:34.148 # Redis version=4.0.8, bits=64, commit=00000000, modified=0, pid=1, just started
redis_1 | 1:C 05 Mar 02:45:34.148 # Configuration loaded
redis_1 | 1:M 05 Mar 02:45:34.150 * Running mode=standalone, port=6379.
redis_1 | 1:M 05 Mar 02:45:34.150 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
redis_1 | 1:M 05 Mar 02:45:34.150 # Server initialized
redis_1 | 1:M 05 Mar 02:45:34.150 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
redis_1 | 1:M 05 Mar 02:45:34.150 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
redis_1 | 1:M 05 Mar 02:45:34.150 # Fatal error loading the DB: Permission denied. Exiting.
redis_1 | 1:C 05 Mar 02:45:40.873 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
redis_1 | 1:C 05 Mar 02:45:40.873 # Redis version=4.0.8, bits=64, commit=00000000, modified=0, pid=1, just started
redis_1 | 1:C 05 Mar 02:45:40.873 # Configuration loaded
redis_1 | 1:M 05 Mar 02:45:40.875 * Running mode=standalone, port=6379.
redis_1 | 1:M 05 Mar 02:45:40.875 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
redis_1 | 1:M 05 Mar 02:45:40.875 # Server initialized
redis_1 | 1:M 05 Mar 02:45:40.875 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
redis_1 | 1:M 05 Mar 02:45:40.875 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
redis_1 | 1:M 05 Mar 02:45:40.875 # Fatal error loading the DB: Permission denied. Exiting.
redis_1 | 1:C 05 Mar 02:45:53.988 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
redis_1 | 1:C 05 Mar 02:45:53.988 # Redis version=4.0.8, bits=64, commit=00000000, modified=0, pid=1, just started
redis_1 | 1:C 05 Mar 02:45:53.988 # Configuration loaded
redis_1 | 1:M 05 Mar 02:45:53.990 * Running mode=standalone, port=6379.
redis_1 | 1:M 05 Mar 02:45:53.990 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
redis_1 | 1:M 05 Mar 02:45:53.990 # Server initialized
redis_1 | 1:M 05 Mar 02:45:53.990 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
redis_1 | 1:M 05 Mar 02:45:53.990 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
redis_1 | 1:M 05 Mar 02:45:53.990 # Fatal error loading the DB: Permission denied. Exiting.
redis_1 | 1:C 05 Mar 02:46:19.904 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
redis_1 | 1:C 05 Mar 02:46:19.904 # Redis version=4.0.8, bits=64, commit=00000000, modified=0, pid=1, just started
redis_1 | 1:C 05 Mar 02:46:19.904 # Configuration loaded
redis_1 | 1:M 05 Mar 02:46:19.906 * Running mode=standalone, port=6379.
redis_1 | 1:M 05 Mar 02:46:19.906 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
redis_1 | 1:M 05 Mar 02:46:19.906 # Server initialized
redis_1 | 1:M 05 Mar 02:46:19.906 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.
redis_1 | 1:M 05 Mar 02:46:19.906 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
redis_1 | 1:M 05 Mar 02:46:19.906 # Fatal error loading the DB: Permission denied. Exiting.
mongodb_1 | 2018-03-05T02:45:23.313+0000 I CONTROL [initandlisten] MongoDB starting : pid=1 port=27017 dbpath=/data/db 64-bit host=bc676a7b9d7a
mongodb_1 | 2018-03-05T02:45:23.313+0000 I CONTROL [initandlisten] db version v3.6.3
mongodb_1 | 2018-03-05T02:45:23.314+0000 I CONTROL [initandlisten] git version: 9586e557d54ef70f9ca4b43c26892cd55257e1a5
mongodb_1 | 2018-03-05T02:45:23.314+0000 I CONTROL [initandlisten] OpenSSL version: OpenSSL 1.0.1t 3 May 2016
mongodb_1 | 2018-03-05T02:45:23.314+0000 I CONTROL [initandlisten] allocator: tcmalloc
mongodb_1 | 2018-03-05T02:45:23.314+0000 I CONTROL [initandlisten] modules: none
mongodb_1 | 2018-03-05T02:45:23.314+0000 I CONTROL [initandlisten] build environment:
mongodb_1 | 2018-03-05T02:45:23.314+0000 I CONTROL [initandlisten] distmod: debian81
mongodb_1 | 2018-03-05T02:45:23.314+0000 I CONTROL [initandlisten] distarch: x86_64
mongodb_1 | 2018-03-05T02:45:23.314+0000 I CONTROL [initandlisten] target_arch: x86_64
mongodb_1 | 2018-03-05T02:45:23.314+0000 I CONTROL [initandlisten] options: { net: { bindIpAll: true } }
mongodb_1 | 2018-03-05T02:45:23.315+0000 I STORAGE [initandlisten] exception in initAndListen: Location28596: Unable to determine status of lock file in the data directory /data/db: boost::filesystem::status: Permission denied: "/data/db/mongod.lock", terminating
mongodb_1 | 2018-03-05T02:45:23.316+0000 I CONTROL [initandlisten] now exiting
mongodb_1 | 2018-03-05T02:45:23.316+0000 I CONTROL [initandlisten] shutting down with code:100
mongodb_1 | 2018-03-05T02:45:25.197+0000 I CONTROL [initandlisten] MongoDB starting : pid=1 port=27017 dbpath=/data/db 64-bit host=bc676a7b9d7a
mongodb_1 | 2018-03-05T02:45:25.197+0000 I CONTROL [initandlisten] db version v3.6.3
mongodb_1 | 2018-03-05T02:45:25.197+0000 I CONTROL [initandlisten] git version: 9586e557d54ef70f9ca4b43c26892cd55257e1a5
mongodb_1 | 2018-03-05T02:45:25.197+0000 I CONTROL [initandlisten] OpenSSL version: OpenSSL 1.0.1t 3 May 2016
mongodb_1 | 2018-03-05T02:45:25.197+0000 I CONTROL [initandlisten] allocator: tcmalloc
mongodb_1 | 2018-03-05T02:45:25.197+0000 I CONTROL [initandlisten] modules: none
mongodb_1 | 2018-03-05T02:45:25.197+0000 I CONTROL [initandlisten] build environment:
mongodb_1 | 2018-03-05T02:45:25.197+0000 I CONTROL [initandlisten] distmod: debian81
mongodb_1 | 2018-03-05T02:45:25.197+0000 I CONTROL [initandlisten] distarch: x86_64
mongodb_1 | 2018-03-05T02:45:25.197+0000 I CONTROL [initandlisten] target_arch: x86_64
mongodb_1 | 2018-03-05T02:45:25.197+0000 I CONTROL [initandlisten] options: { net: { bindIpAll: true } }
mongodb_1 | 2018-03-05T02:45:25.197+0000 I STORAGE [initandlisten] exception in initAndListen: Location28596: Unable to determine status of lock file in the data directory /data/db: boost::filesystem::status: Permission denied: "/data/db/mongod.lock", terminating
mongodb_1 | 2018-03-05T02:45:25.197+0000 I CONTROL [initandlisten] now exiting
mongodb_1 | 2018-03-05T02:45:25.197+0000 I CONTROL [initandlisten] shutting down with code:100
mongodb_1 | 2018-03-05T02:45:26.723+0000 I CONTROL [initandlisten] MongoDB starting : pid=1 port=27017 dbpath=/data/db 64-bit host=bc676a7b9d7a
mongodb_1 | 2018-03-05T02:45:26.723+0000 I CONTROL [initandlisten] db version v3.6.3
mongodb_1 | 2018-03-05T02:45:26.723+0000 I CONTROL [initandlisten] git version: 9586e557d54ef70f9ca4b43c26892cd55257e1a5
mongodb_1 | 2018-03-05T02:45:26.723+0000 I CONTROL [initandlisten] OpenSSL version: OpenSSL 1.0.1t 3 May 2016
mongodb_1 | 2018-03-05T02:45:26.723+0000 I CONTROL [initandlisten] allocator: tcmalloc
mongodb_1 | 2018-03-05T02:45:26.723+0000 I CONTROL [initandlisten] modules: none
mongodb_1 | 2018-03-05T02:45:26.723+0000 I CONTROL [initandlisten] build environment:
mongodb_1 | 2018-03-05T02:45:26.723+0000 I CONTROL [initandlisten] distmod: debian81
mongodb_1 | 2018-03-05T02:45:26.723+0000 I CONTROL [initandlisten] distarch: x86_64
mongodb_1 | 2018-03-05T02:45:26.723+0000 I CONTROL [initandlisten] target_arch: x86_64
mongodb_1 | 2018-03-05T02:45:26.723+0000 I CONTROL [initandlisten] options: { net: { bindIpAll: true } }
mongodb_1 | 2018-03-05T02:45:26.723+0000 I STORAGE [initandlisten] exception in initAndListen: Location28596: Unable to determine status of lock file in the data directory /data/db: boost::filesystem::status: Permission denied: "/data/db/mongod.lock", terminating
mongodb_1 | 2018-03-05T02:45:26.723+0000 I CONTROL [initandlisten] now exiting
mongodb_1 | 2018-03-05T02:45:26.723+0000 I CONTROL [initandlisten] shutting down with code:100
mongodb_1 | 2018-03-05T02:45:27.955+0000 I CONTROL [initandlisten] MongoDB starting : pid=1 port=27017 dbpath=/data/db 64-bit host=bc676a7b9d7a
mongodb_1 | 2018-03-05T02:45:27.955+0000 I CONTROL [initandlisten] db version v3.6.3
mongodb_1 | 2018-03-05T02:45:27.955+0000 I CONTROL [initandlisten] git version: 9586e557d54ef70f9ca4b43c26892cd55257e1a5
mongodb_1 | 2018-03-05T02:45:27.955+0000 I CONTROL [initandlisten] OpenSSL version: OpenSSL 1.0.1t 3 May 2016
mongodb_1 | 2018-03-05T02:45:27.955+0000 I CONTROL [initandlisten] allocator: tcmalloc
mongodb_1 | 2018-03-05T02:45:27.955+0000 I CONTROL [initandlisten] modules: none
mongodb_1 | 2018-03-05T02:45:27.955+0000 I CONTROL [initandlisten] build environment:
mongodb_1 | 2018-03-05T02:45:27.955+0000 I CONTROL [initandlisten] distmod: debian81
mongodb_1 | 2018-03-05T02:45:27.955+0000 I CONTROL [initandlisten] distarch: x86_64
mongodb_1 | 2018-03-05T02:45:27.955+0000 I CONTROL [initandlisten] target_arch: x86_64
mongodb_1 | 2018-03-05T02:45:27.955+0000 I CONTROL [initandlisten] options: { net: { bindIpAll: true } }
mongodb_1 | 2018-03-05T02:45:27.955+0000 I STORAGE [initandlisten] exception in initAndListen: Location28596: Unable to determine status of lock file in the data directory /data/db: boost::filesystem::status: Permission denied: "/data/db/mongod.lock", terminating
mongodb_1 | 2018-03-05T02:45:27.955+0000 I CONTROL [initandlisten] now exiting
mongodb_1 | 2018-03-05T02:45:27.955+0000 I CONTROL [initandlisten] shutting down with code:100
mongodb_1 | 2018-03-05T02:45:29.156+0000 I CONTROL [initandlisten] MongoDB starting : pid=1 port=27017 dbpath=/data/db 64-bit host=bc676a7b9d7a
mongodb_1 | 2018-03-05T02:45:29.156+0000 I CONTROL [initandlisten] db version v3.6.3
mongodb_1 | 2018-03-05T02:45:29.156+0000 I CONTROL [initandlisten] git version: 9586e557d54ef70f9ca4b43c26892cd55257e1a5
mongodb_1 | 2018-03-05T02:45:29.156+0000 I CONTROL [initandlisten] OpenSSL version: OpenSSL 1.0.1t 3 May 2016
mongodb_1 | 2018-03-05T02:45:29.156+0000 I CONTROL [initandlisten] allocator: tcmalloc
mongodb_1 | 2018-03-05T02:45:29.156+0000 I CONTROL [initandlisten] modules: none
mongodb_1 | 2018-03-05T02:45:29.156+0000 I CONTROL [initandlisten] build environment:
mongodb_1 | 2018-03-05T02:45:29.156+0000 I CONTROL [initandlisten] distmod: debian81
mongodb_1 | 2018-03-05T02:45:29.156+0000 I CONTROL [initandlisten] distarch: x86_64
mongodb_1 | 2018-03-05T02:45:29.156+0000 I CONTROL [initandlisten] target_arch: x86_64
mongodb_1 | 2018-03-05T02:45:29.156+0000 I CONTROL [initandlisten] options: { net: { bindIpAll: true } }
mongodb_1 | 2018-03-05T02:45:29.156+0000 I STORAGE [initandlisten] exception in initAndListen: Location28596: Unable to determine status of lock file in the data directory /data/db: boost::filesystem::status: Permission denied: "/data/db/mongod.lock", terminating
mongodb_1 | 2018-03-05T02:45:29.156+0000 I CONTROL [initandlisten] now exiting
mongodb_1 | 2018-03-05T02:45:29.156+0000 I CONTROL [initandlisten] shutting down with code:100
mongodb_1 | 2018-03-05T02:45:31.315+0000 I CONTROL [initandlisten] MongoDB starting : pid=1 port=27017 dbpath=/data/db 64-bit host=bc676a7b9d7a
mongodb_1 | 2018-03-05T02:45:31.315+0000 I CONTROL [initandlisten] db version v3.6.3
mongodb_1 | 2018-03-05T02:45:31.315+0000 I CONTROL [initandlisten] git version: 9586e557d54ef70f9ca4b43c26892cd55257e1a5
mongodb_1 | 2018-03-05T02:45:31.315+0000 I CONTROL [initandlisten] OpenSSL version: OpenSSL 1.0.1t 3 May 2016
mongodb_1 | 2018-03-05T02:45:31.315+0000 I CONTROL [initandlisten] allocator: tcmalloc
mongodb_1 | 2018-03-05T02:45:31.315+0000 I CONTROL [initandlisten] modules: none
mongodb_1 | 2018-03-05T02:45:31.315+0000 I CONTROL [initandlisten] build environment:
mongodb_1 | 2018-03-05T02:45:31.315+0000 I CONTROL [initandlisten] distmod: debian81
mongodb_1 | 2018-03-05T02:45:31.315+0000 I CONTROL [initandlisten] distarch: x86_64
mongodb_1 | 2018-03-05T02:45:31.315+0000 I CONTROL [initandlisten] target_arch: x86_64
mongodb_1 | 2018-03-05T02:45:31.315+0000 I CONTROL [initandlisten] options: { net: { bindIpAll: true } }
mongodb_1 | 2018-03-05T02:45:31.315+0000 I STORAGE [initandlisten] exception in initAndListen: Location28596: Unable to determine status of lock file in the data directory /data/db: boost::filesystem::status: Permission denied: "/data/db/mongod.lock", terminating
mongodb_1 | 2018-03-05T02:45:31.315+0000 I CONTROL [initandlisten] now exiting
mongodb_1 | 2018-03-05T02:45:31.315+0000 I CONTROL [initandlisten] shutting down with code:100
mongodb_1 | 2018-03-05T02:45:34.975+0000 I CONTROL [initandlisten] MongoDB starting : pid=1 port=27017 dbpath=/data/db 64-bit host=bc676a7b9d7a
mongodb_1 | 2018-03-05T02:45:34.975+0000 I CONTROL [initandlisten] db version v3.6.3
mongodb_1 | 2018-03-05T02:45:34.975+0000 I CONTROL [initandlisten] git version: 9586e557d54ef70f9ca4b43c26892cd55257e1a5
mongodb_1 | 2018-03-05T02:45:34.975+0000 I CONTROL [initandlisten] OpenSSL version: OpenSSL 1.0.1t 3 May 2016
mongodb_1 | 2018-03-05T02:45:34.975+0000 I CONTROL [initandlisten] allocator: tcmalloc
mongodb_1 | 2018-03-05T02:45:34.975+0000 I CONTROL [initandlisten] modules: none
mongodb_1 | 2018-03-05T02:45:34.975+0000 I CONTROL [initandlisten] build environment:
mongodb_1 | 2018-03-05T02:45:34.975+0000 I CONTROL [initandlisten] distmod: debian81
mongodb_1 | 2018-03-05T02:45:34.975+0000 I CONTROL [initandlisten] distarch: x86_64
mongodb_1 | 2018-03-05T02:45:34.975+0000 I CONTROL [initandlisten] target_arch: x86_64
mongodb_1 | 2018-03-05T02:45:34.975+0000 I CONTROL [initandlisten] options: { net: { bindIpAll: true } }
mongodb_1 | 2018-03-05T02:45:34.975+0000 I STORAGE [initandlisten] exception in initAndListen: Location28596: Unable to determine status of lock file in the data directory /data/db: boost::filesystem::status: Permission denied: "/data/db/mongod.lock", terminating
mongodb_1 | 2018-03-05T02:45:34.975+0000 I CONTROL [initandlisten] now exiting
mongodb_1 | 2018-03-05T02:45:34.975+0000 I CONTROL [initandlisten] shutting down with code:100
mongodb_1 | 2018-03-05T02:45:41.768+0000 I CONTROL [initandlisten] MongoDB starting : pid=1 port=27017 dbpath=/data/db 64-bit host=bc676a7b9d7a
mongodb_1 | 2018-03-05T02:45:41.768+0000 I CONTROL [initandlisten] db version v3.6.3
mongodb_1 | 2018-03-05T02:45:41.768+0000 I CONTROL [initandlisten] git version: 9586e557d54ef70f9ca4b43c26892cd55257e1a5
mongodb_1 | 2018-03-05T02:45:41.768+0000 I CONTROL [initandlisten] OpenSSL version: OpenSSL 1.0.1t 3 May 2016
mongodb_1 | 2018-03-05T02:45:41.768+0000 I CONTROL [initandlisten] allocator: tcmalloc
mongodb_1 | 2018-03-05T02:45:41.768+0000 I CONTROL [initandlisten] modules: none
mongodb_1 | 2018-03-05T02:45:41.768+0000 I CONTROL [initandlisten] build environment:
mongodb_1 | 2018-03-05T02:45:41.768+0000 I CONTROL [initandlisten] distmod: debian81
mongodb_1 | 2018-03-05T02:45:41.768+0000 I CONTROL [initandlisten] distarch: x86_64
mongodb_1 | 2018-03-05T02:45:41.768+0000 I CONTROL [initandlisten] target_arch: x86_64
mongodb_1 | 2018-03-05T02:45:41.768+0000 I CONTROL [initandlisten] options: { net: { bindIpAll: true } }
mongodb_1 | 2018-03-05T02:45:41.768+0000 I STORAGE [initandlisten] exception in initAndListen: Location28596: Unable to determine status of lock file in the data directory /data/db: boost::filesystem::status: Permission denied: "/data/db/mongod.lock", terminating
mongodb_1 | 2018-03-05T02:45:41.768+0000 I CONTROL [initandlisten] now exiting
mongodb_1 | 2018-03-05T02:45:41.768+0000 I CONTROL [initandlisten] shutting down with code:100
mongodb_1 | 2018-03-05T02:45:54.922+0000 I CONTROL [initandlisten] MongoDB starting : pid=1 port=27017 dbpath=/data/db 64-bit host=bc676a7b9d7a
mongodb_1 | 2018-03-05T02:45:54.922+0000 I CONTROL [initandlisten] db version v3.6.3
mongodb_1 | 2018-03-05T02:45:54.922+0000 I CONTROL [initandlisten] git version: 9586e557d54ef70f9ca4b43c26892cd55257e1a5
mongodb_1 | 2018-03-05T02:45:54.922+0000 I CONTROL [initandlisten] OpenSSL version: OpenSSL 1.0.1t 3 May 2016
mongodb_1 | 2018-03-05T02:45:54.922+0000 I CONTROL [initandlisten] allocator: tcmalloc
mongodb_1 | 2018-03-05T02:45:54.922+0000 I CONTROL [initandlisten] modules: none
mongodb_1 | 2018-03-05T02:45:54.922+0000 I CONTROL [initandlisten] build environment:
mongodb_1 | 2018-03-05T02:45:54.922+0000 I CONTROL [initandlisten] distmod: debian81
mongodb_1 | 2018-03-05T02:45:54.922+0000 I CONTROL [initandlisten] distarch: x86_64
mongodb_1 | 2018-03-05T02:45:54.922+0000 I CONTROL [initandlisten] target_arch: x86_64
mongodb_1 | 2018-03-05T02:45:54.922+0000 I CONTROL [initandlisten] options: { net: { bindIpAll: true } }
mongodb_1 | 2018-03-05T02:45:54.923+0000 I STORAGE [initandlisten] exception in initAndListen: Location28596: Unable to determine status of lock file in the data directory /data/db: boost::filesystem::status: Permission denied: "/data/db/mongod.lock", terminating
mongodb_1 | 2018-03-05T02:45:54.923+0000 I CONTROL [initandlisten] now exiting
mongodb_1 | 2018-03-05T02:45:54.923+0000 I CONTROL [initandlisten] shutting down with code:100
mongodb_1 | 2018-03-05T02:46:20.871+0000 I CONTROL [initandlisten] MongoDB starting : pid=1 port=27017 dbpath=/data/db 64-bit host=bc676a7b9d7a
mongodb_1 | 2018-03-05T02:46:20.871+0000 I CONTROL [initandlisten] db version v3.6.3
mongodb_1 | 2018-03-05T02:46:20.871+0000 I CONTROL [initandlisten] git version: 9586e557d54ef70f9ca4b43c26892cd55257e1a5
mongodb_1 | 2018-03-05T02:46:20.871+0000 I CONTROL [initandlisten] OpenSSL version: OpenSSL 1.0.1t 3 May 2016
mongodb_1 | 2018-03-05T02:46:20.871+0000 I CONTROL [initandlisten] allocator: tcmalloc
mongodb_1 | 2018-03-05T02:46:20.871+0000 I CONTROL [initandlisten] modules: none
mongodb_1 | 2018-03-05T02:46:20.871+0000 I CONTROL [initandlisten] build environment:
mongodb_1 | 2018-03-05T02:46:20.871+0000 I CONTROL [initandlisten] distmod: debian81
mongodb_1 | 2018-03-05T02:46:20.871+0000 I CONTROL [initandlisten] distarch: x86_64
mongodb_1 | 2018-03-05T02:46:20.871+0000 I CONTROL [initandlisten] target_arch: x86_64
mongodb_1 | 2018-03-05T02:46:20.871+0000 I CONTROL [initandlisten] options: { net: { bindIpAll: true } }
mongodb_1 | 2018-03-05T02:46:20.871+0000 I STORAGE [initandlisten] exception in initAndListen: Location28596: Unable to determine status of lock file in the data directory /data/db: boost::filesystem::status: Permission denied: "/data/db/mongod.lock", terminating
mongodb_1 | 2018-03-05T02:46:20.871+0000 I CONTROL [initandlisten] now exiting
mongodb_1 | 2018-03-05T02:46:20.871+0000 I CONTROL [initandlisten] shutting down with code:100
xunsearch_1 | 2018-03-05 02:45:24 searchd[13] ALERT spawned child worker[1] (PID:14)
xunsearch_1 | 2018-03-05 02:45:24 searchd[13] ALERT spawned child worker[2] (PID:15)
xunsearch_1 | 2018-03-05 02:45:24 searchd[13] ALERT spawned child worker[3] (PID:16)
xunsearch_1 | 2018-03-05 02:45:24 ~master[13] NOTICE ready for system signal (WORKER_NUM:3)
xunsearch_1 | 2018-03-05 02:45:24 worker2[15] ALERT worker server start
xunsearch_1 | 2018-03-05 02:45:24 worker2[15] NOTICE event loop start (EVENT:0x0002, FLAG:0x0004)
xunsearch_1 | 2018-03-05 02:45:24 worker3[16] ALERT worker server start
xunsearch_1 | 2018-03-05 02:45:24 worker3[16] NOTICE event loop start (EVENT:0x0002, FLAG:0x0004)
xunsearch_1 | 2018-03-05 02:45:24 worker1[14] ALERT worker server start
xunsearch_1 | 2018-03-05 02:45:24 worker1[14] NOTICE event loop start (EVENT:0x0002, FLAG:0x0004)
xunsearch_1 | tail: unrecognized file system type 0x794c7630 for 'tmp/docker.log'. please report this to bug-coreutils@gnu.org. reverting to polling
共收到 6 条回复
Fecshop#19个月前 0 个赞

https://stackoverflow.com/questions/37471929/docker-container-keeps-on-restarting-again-on-again

参看下这个,排查一下试试,这个和你的报错是一样的,我没有遇到过你这种类型的报错。

Fecshop#29个月前 0 个赞

资料:http://gdocker.com/640/dockercontainer.html

排查一下看看,如果解决了,分享一下你如何解决的

MYYY#39个月前 0 个赞

解决了吗、? 解决了分享一下。

群主用的是在阿里云环境配置的,您的是win下面的docker配置的,可能有点差异。

如果解决了,分享一下。

Fecshop#49个月前 0 个赞

vbox虚拟的centos中,安装docker ,在安装fecshop的方式没有试过

github docker 部分是在阿里云centos7下搭建的,搭建好后,同时,也有不少fecshoper按照文档搭建成功了, ,没有遇到你的这个问题。

请问您现在解决这个问题了吗?如果解决了,分享一下,帮助一下其他人。

airycanon#59个月前 1 个赞

sudo docker-compose exec mysql bash 时出现如下错误: Error response from daemon: Container

原因是 Mysql 启动失败了,再看下面的错误信息

mysqld: Can't read dir of '/etc/mysql/conf.d/' (Errcode: 13 - Permission denied)

根本原因是 MySQL 读取配置文件时没有权限,Linux 下请执行

chmod 644 ./db/mysql/conf.d

Windows 请自行查找设置方法。

Fecshop#69个月前 0 个赞

@airycanon #5楼 多谢分享。

添加回复 (需要登录)
需要 登录 后方可回复, 如果你还没有账号请点击这里 注册
Your Site Analytics