centos6 安装 git2.7

Linux · Fecshop · 于 3个月前 发布 · 155 次阅读

在使用 go get 安装gin框架的时候,遇到了坑,centos 6 默认的git是1.7.1,导致安装一直卡住,后来查阅文章:https://github.com/go-playground/validator/issues/224

发现,是centos自带的git版本太低的问题导致的,于是,卸掉git ,重新安装2.7.2

卸载Centos自带的git1.7.1 通过git –version查看系统带的版本,Cento6.5应该自带的是git版本是1.7.1

yum remove git

安装依赖:

yum install curl-devel expat-devel gettext-devel openssl-devel zlib-devel
yum install gcc perl-ExtUtils-MakeMaker

下载git最新版本

cd /tools
wget https://www.kernel.org/pub/software/scm/git/git-2.7.2.tar.gz
tar xzf git-2.7.2.tar.gz

安装git,然后将其添加到环境变量,命令操作如下:

cd git-2.7.2
make prefix=/usr/local/git all
make prefix=/usr/local/git install
vim /etc/profile
// 在末尾新开一行填写下面的代码
export PATH=$PATH:/usr/local/git/bin
// :wq保存退出,然后执行下面的命令,让其生效
source /etc/profile

到这里就安装成功了,查看git版本号

git –version
git version 2.7.2
共收到 0 条回复
没有找到数据。
添加回复 (需要登录)
需要 登录 后方可回复, 如果你还没有账号请点击这里 注册
Your Site Analytics