xi_qing

第 23 位会员

会员
个人信息
  • 加入于 2017-06-02 09:46:48
  • 最后登录时间 11个月前
个人成就
  • 发表文章次数 13
  • 发布回复次数 25
  • 个人主页浏览次数 4
同一订单中同一产品:评论时如何判断重复评论11个月前

不太明白你想表达的是什么,什么交如何判断重复评论,业务场景描述清楚一点

安装报错11个月前

你这个我也没遇到过,看着像是composer加载的时候出现问题。你可以试试下面的语句

composer self-update
composer global require "fxp/composer-asset-plugin:^1.3.1"

试试看更新了composer之后会不会出现,我之前在安装YII2的时候没有更新也会出问题,记得翻墙或者切换国内镜像

composer安装报错11个月前

这个是你的网络不能访问国外的资源导致的,你可以使用vpn翻墙或者使用中国镜像

composer config -g repo.packagist composer https://packagist.phpcomposer.com

另外你在安装前执行下面语句了没

composer global require "fxp/composer-asset-plugin:^1.3.1"
windows下,网站根目录下1年前

还是不行的话就按照这个http://www.fecshop.com/topic/402 重新搭建一下环境

windows下,网站根目录下1年前

@wqzjd #13楼 不要后面的php.exe,之前都没有设置过环境变量吗?你这样截一个图谁会哪里明白你要表达什么

windows下,网站根目录下1年前

@wqzjd #8楼 你去设置windows的环境变量,不是在这里改,怎么设置windows环境变量百度一下就知道了

windows下,网站根目录下1年前

昨天可以的话,看下是否有动过什么导致@别名无法找到路径,你可以设置成绝对路径执行看看

yii mongodb-migrate --interactive=0 --migrationPath=D:\www\fecshop\vendor\fancyecommerce\fecshop\migrations\mongodb/migrations/mongodb
fecshop产品属性疑问1年前

我对上面的代码改了一下可以出来,其他流程还测试看会不会影响

public function getAllItems()
    {
        $custom_option_attr_info = Yii::$service->product->getCustomOptionAttrInfo($this->attr_group);

        //#########
        $my_arr = [];
        $arr = [];
        //#在custom_option里面第一个属性
        $img_attr = '';
        if (is_array($custom_option_attr_info) && !empty($custom_option_attr_info)) {
            foreach ($custom_option_attr_info as $attr => $info) {
                if (isset($info['showAsImg']) && $info['showAsImg']) {
                    $img_attr = $attr;
                    break;
                }
            }
        }
        $img_arr = [];
        if (is_array($this->custom_option) && (!empty($this->custom_option))) {
            foreach ($this->custom_option as $option) {
                $qty = $option['qty'];
                if ($qty > 0) {
                    $this->_custom_option_arr[] = $option;
                    if (isset($option[$img_attr])) {
                        $val = $option[$img_attr];
                        $img_arr[$val] = $option['image'];
                    }
                    foreach ($option as $k=>$v) {
                        $my_arr[$k][] = $v;
                    }
                }
            }
        }
        if (is_array($custom_option_attr_info) && !empty($custom_option_attr_info)) {
            foreach ($custom_option_attr_info as $attr => $info) {
                if (isset($info['display']['type']) && ($info['display']['type'] == 'select')) {
                    if (isset($info['display']['data']) && is_array($info['display']['data'])) {
                        foreach ($info['display']['data'] as $key=>$val) {
                            if (is_array($my_arr[$attr]) && in_array(htmlspecialchars($key), $my_arr[$attr])) {
                                $t_arr = [
                                    'key' => $key,
                                    'val' => $val,
                                ];
                                $require = isset($info['require']) ? $info['require'] : 0;
                                if (isset($info['showAsImg']) && $info['showAsImg']) {
                                    if (isset($img_arr[htmlspecialchars($key)])) {
                                        $t_arr['image'] = $img_arr[htmlspecialchars($key)];
                                    }
                                }
                                $arr[$attr]['info'][] = $t_arr;
                                $arr[$attr]['require'] = $require;
                            }
                        }
                    }
                }
            }
        }

        return $arr;
    }

增加了对$key的html转义

刚安装 分类导航 不显示分类1年前

分类不显示看下数据里面的menu_show是否为1,后面的版本增加了这个属性,如果导入的时候旧数据的话也会导致分类不显示。因为缺少了menu_show字段

PHP Parse Error 'yii\base\ErrorException' with message 'syntax error, unexpected '::'1年前

我这边更新新版本后打开页面也会出现这个问题,目前还在看什么原因

feshop结合vue问题咨询1年前

@Terry #1楼 那vue中动态调用的接口连接是否统一写在appserver中呢?各个store只是做初始页面的判断调用,相当于store路由?

configure: error: utf8_mime2text() has new signature, but U8T_CANONICAL is missing. This should not happen. Check config.log for additional information.1年前

你libc-client-devel有安装完成吗?有安装完成应该不会出现这个情况的,在执行

./configure --with-php-config=/usr/local/php/bin/php-config --with-imap=/usr/lib64 --with-imap-ssl --with-kerberos

这个之前有执行

/usr/local/php/bin/phpize

吗? 安装的时候没出现过你这个情况,有空的时候我重新装一下看看

关于fecshop升级的疑问1年前

@water #2楼 好的,我先用复制过来的方式修改,做的过程中看想想看有没有其他的方式来弄,主要是考虑到有新增需求的时候会有微调的情况,这样升级就变的麻烦了。慢慢完善吧

fecshop分类问题1年前

@water #2楼 嗯,谢谢

PHP Parse error: syntax error, unexpected end of file in - on line 494 遇到这个问题1年前

我上次用这种方式也是请求不到,一直装不了,你试试composer官网提示的方式看看

php -r "copy('https://getcomposer.org/installer', 'composer-setup.php');"
php -r "if (hash_file('SHA384', 'composer-setup.php') === '669656bab3166a7aff8a7506b8cb2d1c292f042046c5a994c43155c0be6190fa0355160742ab2e1c88d40d5be660b410') { echo 'Installer verified'; } else { echo 'Installer corrupt'; unlink('composer-setup.php'); } echo PHP_EOL;"
php composer-setup.php
php -r "unlink('composer-setup.php');"
关于fecshop中classMap使用的问题1年前

@water #2楼 嗯嗯,明白了,现在可以用了,谢谢!也为自己的不细心感到抱歉!

首页加载无样式1年前

为什么404的这个地址上会带有8080端口,是否与这个有关,试试看

wamp2.5下安装fecshop失败之mongodb扩展问题1年前

1、fecshop肯定是支持php5的,本人就在php5.6的环境下可以跑起来,这个是肯定的 2、你在composer update的时候提示未安装mongodb,这个错误肯定是mongodb的扩展没有装好,你可以看下是不是下载的mongodb的版本跟你的php不一直,如php是64位的你装了32位扩展,或者你的php是非线程安全的,但是你装了线程安全的扩展,均会导致匹配不到,最好是检查一下。

Your Site Analytics