myred08

第 369 位会员

会员
个人信息
  • 加入于 2018-03-07 11:20:25
  • 最后登录时间 2天前
个人成就
  • 发表文章次数 13
  • 发布回复次数 56
  • 个人主页浏览次数 16
Url类的getCurrentUrl()方法判断HTTPS出错3个月前

$http_type = ((isset($_SERVER['HTTPS']) && (strcasecmp($_SERVER['HTTPS'], 'on') === 0 || $_SERVER['HTTPS'] == 1)) || (isset($_SERVER['HTTP_X_FORWARDED_PROTO']) && strcasecmp($_SERVER['HTTP_X_FORWARDED_PROTO'], 'https') === 0)) ? 'https://' : 'http://'; 

Url类的getCurrentUrl()方法判断HTTPS出错3个月前

Yii2有一个函数可以判断

$secure = Yii::$app->getRequest()->getIsSecureConnection();
            $http = $secure ? 'https' : 'http';
    /**
     * Return if the request is sent via secure channel (https).
     * @return bool if the request is sent via secure channel (https)
     */
    public function getIsSecureConnection()
    {
        if (isset($_SERVER['HTTPS']) && (strcasecmp($_SERVER['HTTPS'], 'on') === 0 || $_SERVER['HTTPS'] == 1)) {
            return true;
        }
        foreach ($this->secureProtocolHeaders as $header => $values) {
            if (($headerValue = $this->headers->get($header, null)) !== null) {
                foreach ($values as $value) {
                    if (strcasecmp($headerValue, $value) === 0) {
                        return true;
                    }
                }
            }
        }

        return false;
    }

在前台下单填地址的那框,测试到的两个XSS注入点,可能是吧?4个月前

Add new address的哪一排框框大部分都是可以注入。连洲省框都是可以的。

在前台下单填地址的那框,测试到的两个XSS注入点,可能是吧?4个月前

好像可以做很多事哇。 可以打开新网页。获取当前浏览器网址等等。。会爆出后台管理的URL :worried: :worried: :worried: :worried: :disappointed_relieved:

在后台添加上作者新开发的管理”订阅“的功能,有个弹出框框。4个月前

@Dongtan [[[#1楼](#comment1)](#comment1)](#comment1) 感谢你的解惑,确实是有人加了XSS测试代码

javascript:alert(1987)
db.newsletter.find({email:{$not: /@/}})

后台可以解析base64编码的数据。有点怪。

弱弱的问一下关于composer update的问题4个月前

@Terry #7楼 恩,就等全没问题的一天。

弱弱的问一下关于composer update的问题4个月前

@Terry #5楼 搞定了。 升级前有更新composer

composer selfupdate

弱弱的问一下关于composer update的问题4个月前

@Terry #1楼 确实是这个问题。把镜像改成中国的了。 按这边http://www.fancyecommerce.com/2017/04/19/composer-默认地址改为中国镜像地址,以及中国镜像地址/ 的恢复了

composer update后提示

Updating dependencies (including require-dev)                                             Your requirements could not be resolved to an installable set of packages.                               

  Problem 1
    - Installation request for fancyecommerce/fecshop >=1.4.3.0 -> satisfiable by fancyecommerce/fecshop[1.4.3.0].
    - fancyecommerce/fecshop 1.4.3.0 requires hightman/xunsearch 1.4.12-beta1 -> satisfiable by hightman/xunsearch[1.4.12-beta1] but these conflict with your requirements or minimum-stability.

[root@localhost fecshop]# 

为什么分类和产品页面,产品价格以格式 xx.00方式显示(价格和特价),首页单单跳过?4个月前

@Terry #1楼 恩,搞定了。主要是文件路径不熟悉。 现在找到了 在 \vendor\fancyecommerce\fecshop\app\appfront\theme\base\front\cms\home\index\price.php

把
$price['value']
改成 Yii::$service->helper->format->number_format($price['value']) 

就OK了。

PHPStudy下安装Fecshop全过程4个月前

建议认真看作者的安装说明吧。 你都没看说明。直接上来问了。 作者都被搞烦了。 :(
嘿嘿。

PHPStudy下安装Fecshop全过程4个月前

不一样。建议你用https://pan.baidu.com/s/1hs1iC2C#list/path=/fecshop 下载 这边的下载。 github的楼主是分模块。你这个好像不完整的。

PHPStudy下安装Fecshop全过程4个月前

@davin #31楼 我说的是

init.bat

PHPStudy下安装Fecshop全过程4个月前

@davin [#28楼](#comment28) 亲,是 init.bat 不是init吧? 你是windows环境的。要用批处理执行。

Your Site Analytics